您的位置:首页 > 其它

poj 2151 Check the difficulty of problems

2016-08-11 10:42 435 查看
Check the difficulty of problems

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6782 Accepted: 2944
Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 

1. All of the teams solve at least one problem. 

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you
calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines,
the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output
0.972

Source

POJ Monthly,鲁小石

以下是转载

<span style="color: rgb(204, 0, 0);">题意:有t支队伍,m道题,冠军最少做n道题,问保证每队最少做一题,冠军最少做n题的概率</span>


/*



*/

提示:一定要对数据初始化。题意是每组最少做出来一题啊!!!

我的这次代码写的很用心,以后我会对我的每一个代码负责,用心写他们

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
using namespace std;

double dp[1002][35][35];
double bility[1002][35];
double Bil[1002][35];
int m,t,n;

void init ()
{
int i, k, j;

memset (dp, 0, sizeof(dp));
memset (Bil, 0, sizeof(Bil));

for ( i = 1;i <= t; i++ )
{
for ( j = 1;j <= m; j++ )
{
dp[i][j][0] = 1;
for ( k = 1;k <= j; k++ )
{
dp[i][j][0] = dp[i][j][0]*(1.0-bility[i][k]);
}
}
dp[i][0][0] = 1;
}
}

void BIL ()
{
int i, j, k;

for ( i = 1;i <= t; i++ )
{
for ( j = 1;j <= m; j++ )
{
for ( k = 1;k <= m; k++ )
{
dp[i][j][k] = dp[i][j-1][k]*(1-bility[i][j])+dp[i][j-1][k-1]*bility[i][j];
}
}
}
for ( i = 1;i <= t; i++ )
{
for ( j = 1;j <= m; j++ )
{
Bil[i][j] = Bil[i][j-1]+dp[i][m][j];
}
}
}

double num ()
{
int i;
double sum1 = 1.0, sum2 = 1.0;

for( i = 1; i <= t; i++ )
{
sum1 = sum1*(Bil[i][m]-Bil[i][0]);
}
for( i = 1; i <= t; i++ )
{
sum2 = sum2*(Bil[i][n-1]-Bil[i][0]);
}

return sum1-sum2;
}

int main()
{
int i, j;

while ( ~scanf ( "%d %d %d", &m, &t, &n ) && ( n != 0||m != 0||t != 0 ))
{
/*Data input  数据输入*/
for ( i = 1;i <= t; i++ )
{
for ( j = 1;j <= m; j++ )
{
scanf ( "%lf", &bility[i][j] );
}
}

/*Data initialization 数据初始化*/
init();

/*The calculation of the probability
概率的计算*/
BIL ();

/*Final number  最终数值*/
printf ( "%.3f\n", num() );
}
}


代码菜鸟,如有错误,请多包涵!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: