您的位置:首页 > 其它

HDOJ -- 1222 Wolf and Rabbit

2016-08-10 20:54 330 查看

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

[align=left]Problem Description[/align]
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 
[align=left]Input[/align]
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
[align=left]Output[/align]
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
[align=left]Sample Input[/align]

2
1 2
2 2

[align=left]Sample Output[/align]

NO
YES

 
[align=left]解题思路:怎么说呢。。读懂题意很重要,这些洞围成一个环圆,那只犯傻的狼循环着跑。。循环着跑。。无数次。。[/align]
[align=left]其实就是问你狼能否在无数次的进洞后,把所有的洞都进完!如果可以,那么兔子就意味着要遭殃了;如果不能(即陷入了循环),那么兔子就是安全的。[/align]
[align=left]据说这是个常识:如果两个数互质(即最大公约数为1),那么狼一定能进完所有的洞;否则,陷入循环。[/align]
#include<stdio.h>
int gcd(int a,int b){
if(a%b==0)
return b;
return gcd(b,a%b);
}//递归求最大公约数
int main(){
int m,n,t;
scanf("%d",&t);
while(t--){
scanf("%d%d",&m,&n);
if(gcd(m,n)==1)
printf("NO\n");
else
printf("YES\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  说水不水