您的位置:首页 > 其它

POJ 1007 DNA Sorting

2016-08-10 17:48 302 查看
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 96039 Accepted: 38659
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

练习写归并排序。
#include<stdio.h>
#include<string.h>
struct Array{
char s[50];
int num;
}array[100];
int countnum(char s[], int len){
int i, j, count = 0;;
for(i = 0; i < len - 1; i ++){
for(j = i + 1; j < len; j ++){
if(s[i] > s[j]){
count ++;
}
}
}
return count;
}
void merge(struct Array temparray[], int left, int right){
int index1, index2, i, middle, count = left;
for(i = left; i <= right; i ++){
temparray[i].num = array[i].num;
strcpy(temparray[i].s, array[i].s);
}
index1 = left;
middle = (left + right) / 2;
index2 = middle + 1;
while(index1 <= middle && index2 <= right){
if(temparray[index1].num <= temparray[index2].num){
array[count].num = temparray[index1].num;
strcpy(array[count ++].s, temparray[index1 ++].s);
}else{
array[count].num = temparray[index2].num;
strcpy(array[count ++].s, temparray[index2 ++].s);
}
}
while(index1 <= middle){
array[count].num = temparray[index1].num;
strcpy(array[count ++].s, temparray[index1 ++].s);
}
while(index2 <= right){
array[count].num = temparray[index2].num;
strcpy(array[count ++].s, temparray[index2 ++].s);
}
}
void mergesort(struct Array temparray[], int left, int right){
int middle = (left + right) / 2;
if(left < right){
mergesort(temparray, left, middle);
mergesort(temparray, middle + 1, right);
merge(temparray, left, right);
}
}
int main(){
int m, n, i;
struct Array temparray[100];
scanf("%d %d", &n, &m);
for(i = 0; i < m; i ++){
scanf("%s", array[i].s);
}
for(i = 0; i < m; i ++){
array[i].num = countnum(array[i].s, n);
}
mergesort(temparray, 0, m - 1);
for(i = 0; i < m; i ++){
printf("%s\n", array[i].s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: