您的位置:首页 > 其它

HDU1027——Ignatius and the Princess II(全排列)

2016-08-10 16:38 393 查看
[align=center]Ignatius and the Princess II[/align]
[align=center][/align]
[align=center]点击乘坐筋斗云[/align]
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6991    Accepted Submission(s): 4140


[align=left]Problem Description[/align]
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have
three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once
in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"

Can you help Ignatius to solve this problem?

 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input
is terminated by the end of file.

 

[align=left]Output[/align]
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last
number.

 

[align=left]Sample Input[/align]

6 4
11 8

 

[align=left]Sample Output[/align]

1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
题意: 求N个数全排列,顺着数第M个(不知道能理解不);
解题思路: 先看m有大多,需要调整的数有几位,(比如m=4,那么就需要调整3位,因为2!<4<3!),咱们用t表示,再算出t-1位可以调整多少次(sum次),与m相比,若m能减去i个sum且m>0,说明下一位是后t位第i+1小的数,依次循环(这时需要调整的剩t-1位)。
代码实现(本人代码比较乱,建议看第二个,这个是给自己看的):
#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long LL;
const int maxn = 1000000+10;
int num[1000];
int n,m;

int main()
{
while( ~scanf("%d%d",&n,&m) )
{
if( n==1 ){
printf("1\n");
continue;
}
memset(num,0,sizeof(num));
for( int i=1; i<=n; i++ )
num[i] = i;
int yu,t=1;
for( int i=2; i<=9; i++ )
{
yu = m - t;
if( yu<=0 )
{
t = i-1;
break;
}
t *= i;
}
for( int i=1; i<=n-t; i++ )
printf("%d ",num[i]);
vector<int>v;
for( int i=n-t+1; i<=n; i++ )
v.push_back(num[i]);
int ans = n-t;
while( m )
{
int lu,i,j;
lu = n - ans - 1;
int sum=1;
for( i=1; i<=lu; i++ )
sum *= i;
if( lu == 0 )
sum = 0;
for( i=1; i<=lu; i++ )
{
if( m-sum <=0 )
break;
m = m - sum;
}
if( lu==0 && m==1 )
printf("%d\n",v[i-1]);
else
printf("%d ", v[i-1]);
v.erase(v.begin()+i-1);
ans++;
if( ans == n )
break;
}
}
return 0;
}


咱们看神奇的第二种方法: 直接调用函数:STL库函数next_permutation(startAddress,endAddress)
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int N,M;
int sequence[1010];
int main()
{
setbuf(stdout,NULL);
while(scanf("%d %d",&N,&M)!=EOF)
{
int i;
for(i=0;i<N;i++)
{
sequence[i]=i+1;
}
for(i=2;i<=M;i++)
{
next_permutation(sequence,sequence+N);
}
for(i=0;i<N-1;i++)
{
printf("%d ",sequence[i]);
}
printf("%d\n",sequence[N-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: