您的位置:首页 > 其它

HDU 1501 Zipper

2016-08-10 15:58 344 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1501

Zipper

Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3

cat tree tcraete

cat tree catrtee

cat tree cttaree

Sample Output

Data set 1: yes

Data set 2: yes

Data set 3: no

题意

这个题是说给你三个字符串,你判断第三个能不能由前两个组成,而且前两个字符串的顺序是不可以乱的。

就比如上述的案例 。

把字符串从前往后看,它的第一个字符是第一个或者第二个的第一个字符,选定后,做个标记,继续往后,倒数第二个是除去上面那个,新的字符串的第一个或者第二个的第一个字符,依次论推。

#include <stdio.h>
#include <iostream>
#include<math.h>
#include <string.h>
#include <algorithm>
using namespace std;
char a[201],b[201],c[402];
int dp[201][201];
int main()
{
int t,i,j,la,lb,ca;
scanf("%d",&t);
for(ca=1;ca<=t;ca++)
{
scanf("%s%s%s",a+1,b+1,c+1);
la=strlen(a+1);
lb=strlen(b+1);
memset(dp,0,sizeof(dp));
for(i=1;i<=la;i++)
if(a[i]==c[i])
dp[i][0]=1;
for(i=1;i<=lb;i++)
if(b[i]==c[i])
dp[0][i]=1;
for(i=1;i<=la;i++)
for(j=1;j<=lb;j++)
dp[i][j]=(dp[i-1][j]&&(a[i]==c[i+j]))||(dp[i][j-1]&&(b[j]==c[i+j]));
printf("Data set %d: ",ca);
if(dp[la][lb]==1)
printf("yes\n");
else
printf("no\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: