您的位置:首页 > 其它

Balls and Boxes

2016-08-10 09:28 204 查看

Balls and Boxes

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 213    Accepted Submission(s): 157
[/b]

[align=left]Problem Description[/align]
Mr. Chopsticks is interested in random phenomena, and he conducts an experiment to study randomness. In the experiment, he throws n balls into m boxes in such a manner that each ball has equal probability of going to each boxes. After
the experiment, he calculated the statistical variance V as

V=∑mi=1(Xi−X¯)2m

where Xi
is the number of balls in the ith box, and X¯
is the average number of balls in a box.

Your task is to find out the expected value of V.

 

[align=left]Input[/align]
The input contains multiple test cases. Each case contains two integers n and m (1 <= n, m <= 1000 000 000) in a line.

The input is terminated by n = m = 0.

 

[align=left]Output[/align]
For each case, output the result as A/B in a line, where A/B should be an irreducible fraction. Let B=1 if the result is an integer.
 

[align=left]Sample Input[/align]

2 1
2 2
0 0

 

[align=left]Sample Output[/align]

0/1
1/2规律题:(m-1)*n/(m*m);
#include<stdio.h>
long long int gcd(long long int a,long long int b)
{
if(b==0)
return a;
else
return gcd(b,a%b);
}
int main()
{
long long int n,m;
while(scanf("%lld%lld",&n,&m)!=-1)
{
if(n==0&&m==0)
break;
long long int sum=(m-1)*n;
long long int ni=m*m;
long long int we=gcd(sum,ni);
sum=sum/we;
ni=ni/we;
printf("%lld/%lld\n",sum,ni);
}
}

HintIn the second sample, there are four possible outcomes, two outcomes with V = 0 and two outcomes with V = 1.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: