您的位置:首页 > 其它

hdoj 1069

2016-08-09 21:35 134 查看

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12768    Accepted Submission(s): 6691


[align=left]Problem Description[/align]
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall
be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

[align=left]Input[/align]
The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 

[align=left]Output[/align]
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 

[align=left]Sample Input[/align]

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

[align=left]Sample Output[/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 每个长方体可以有六种摆放方式(长和宽可交换),上面的要求长和宽都比下面的小,问最高的高度。
先按长和宽的面积从(排列长宽而不是相乘的面积)大到小排列;
然后就模型:最长递减序列
3 7 5 6 9 8 13

3
7 5
9 6
13 9 

  13 

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct  Block
{
int l,w,h;
}B[210];
bool cmp(Block x,Block y)
{
if(x.l==y.l)
return x.w>y.w;
return x.l>y.l;
}
int main()
{
int n,a,b,c;
int k,Kcase=1;
int i,j;
int dp[210];
while(scanf("%d",&n)&&n)
{
k=0;
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
{
scanf("%d%d%d",&a,&b,&c);
B[k].l=a; B[k].w=b; B[k].h=c; k++;
B[k].l=b; B[k].w=a; B[k].h=c; k++;
B[k].l=a; B[k].w=c; B[k].h=b; k++;
B[k].l=c; B[k].w=a; B[k].h=b; k++;
B[k].l=b; B[k].w=c; B[k].h=a; k++;
B[k].l=c; B[k].w=b; B[k].h=a; k++;
}
sort(B,B+k,cmp);
dp[0]=B[0].h;
int ans=dp[0];
for(i=1;i<k;i++)
{
for(j=0;j<=i;j++)//第i个长方体加在已经排好的序列上之后得到的最优解(最高)
{
if(B[i].l<B[j].l&&B[i].w<B[j].w)
dp[i]=max(dp[i],dp[j]);
}
dp[i]+=B[i].h;
ans=max(ans,dp[i]);
}
printf("Case %d: maximum height = %d\n",Kcase++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: