您的位置:首页 > 其它

HDU 3555 数位dp

2016-08-09 18:58 183 查看

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 15072 Accepted Submission(s): 5441


[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.

[align=left]Sample Input[/align]

3
1
50
500

[align=left]Sample Output[/align]

0
1
15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

[align=left]Author[/align]
fatboy_cw@WHU

[align=left]Source[/align]
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

题意:求1~n闭区间内含有“49”的数的个数

题解:

dp[i][2] 长度为i 含有“49”的个数

dp[i][1] 长度为i 不含有“49”但是高位为“9”的个数

dp[i][0] 长度为i 不含有“49”的个数

数组 a[i] 从低位到高位存储 n 的每一位数字。

dp[i][2]=dp[i-1][2]*10+dp[i-1][1]; //考虑第i位为“4” i-1位为“9”

dp[i][1]=dp[i-1][0];

dp[i][0]=dp[i-1][0]*10-dp[i-1][1];

对于n处理之前为什么要自增1

因为题目要求处理的是闭区间 可能自增1当作开区间处理

http://www.cnblogs.com/liuxueyang/archive/2013/04/14/3020032.html

/******************************
code by drizzle
blog: www.cnblogs.com/hsd-/
^ ^    ^ ^
O      O
******************************/
//#include<bits/stdc++.h>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<map>
#include<algorithm>
#include<queue>
#define ll __int64
using namespace std;
int t;
ll n;
ll a[65];
ll dp[65][5];
void init()
{
dp[0][0]=1;
for(int i=1; i<=22; i++)
{
dp[i][0]=10*dp[i-1][0]-dp[i-1][1];
dp[i][1]=dp[i-1][0];
dp[i][2]=10*dp[i-1][2]+dp[i-1][1];
}
}
int main()
{
init();
while(scanf("%d",&t)!=EOF)
{
for(int i=1; i<=t; i++)
{
scanf("%I64d",&n);
memset(a,0,sizeof(a));
int len=1;
n++;
while(n)
{
a[len]=n%10;
n=n/10;
len++;
}
int flag=0;
int last=0;
ll ans=0;
for(int j=len; j>=1; j--)
{
ans+=dp[j-1][2]*a[j];
if(flag)
ans+=dp[j-1][0]*a[j];
if(!flag&&a[j]>4)
ans+=dp[j-1][1];
if(last==4&&a[j]==9)
flag=1;
last=a[j];
}
printf("%I64d\n",ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: