您的位置:首页 > 其它

poj 1611 The Suspects

2016-08-09 15:13 288 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 33800Accepted: 16386
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source

Asia Kaohsiung 2003

/*

有一个学校,有N个学生,编号为0-N-1,现在0号学生感染了非典,凡是和0在一个社团的人就会感染,并且这些人如果还参加了别的社团,他所在的社团照样全部感染,求感染的人数。

*/
这是一个并查集的题,很容易想的
一下是代码
#include<iostream>
#include<cstring>
#include<cstdio>
#define N 30010
using namespace std;

int a
, b
, c
;    //a数组就是并查集数组了,b记录的是人数,c仅仅是我方便储存的数组
int n,m;

void init()                      //初始化
{
for( int i = 0; i < n; i++ )
{
a[i] = i;
b[i] = 1;
}
}

int find( int x )           //查找根
{
while( x != a[x] )
{
x = a[x];
}
return x;
}

void me( int x, int y )
{
int fx = find(x);
int fy = find(y);
if ( fx != fy )
{
a[fy] = fx;                          //改变根的值
b[fx] = b[fx] + b[fy];                 //添加人数
}
}

int main()
{
int t;
while( ~scanf( "%d %d", &n, &m ) && ( n != 0 || m != 0 ) )
{
init();
for ( int i = 0;i < m; i++ )
{
scanf( "%d", &t );
for ( int j = 0;j < t; j++ )
{
scanf ( "%d" , &c[j] );
if ( j > 0 )
me( c[j-1], c[j] );
}
}
printf ( "%d\n", b[find(0)] );
}
return 0;
}


我今天看了一个最大流的代码,我感觉他们写的代码都好“干净”啊!就是写的令人赏心悦目!
以后我也要注意我的版面了!
代码菜鸟,如有错误,请多包涵!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: