您的位置:首页 > 其它

POJ 3255 Roadblocks(A*求次短路)

2016-08-09 13:11 453 查看
Roadblocks

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12167 Accepted: 4300
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the
shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination)
is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if
two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output
450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
Source

USACO 2006 November Gold

题目链接:POJ 3255

裸的A*,注意一点题目要强行次短路,不存在次短就来回跑一圈再跑到终点(MDZZ)……

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<bitset>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(x,y) memset(x,y,sizeof(x))
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
typedef pair<int,int> pii;
typedef long long LL;
const double PI=acos(-1.0);
const int N=100010;
struct edge
{
int to;
int pre;
int dx;
};
struct info
{
int cur;
int g;
int h;
int f;
bool operator<(const info &b)const
{
return f>b.f;
}
};
info S;
edge E[N<<1];
int head[N<<1],ne;
int d
;
priority_queue<info>q;
void add(int s,int t,int d)
{
E[ne].to=t;
E[ne].dx=d;
E[ne].pre=head[s];
head[s]=ne++;
}
void init()
{
CLR(head,-1);
ne=0;
CLR(d,INF);
while (!q.empty())
q.pop();
}
void spfa(int s)
{
priority_queue<pii>Q;
d[s]=0;
Q.push(pii(-d[s],s));
while (!Q.empty())
{
int now=Q.top().second;
Q.pop();
for (int i=head[now]; ~i; i=E[i].pre)
{
int v=E[i].to;
int w=E[i].dx;
if(d[v]>d[now]+w)
{
d[v]=d[now]+w;
Q.push(pii(-d[v],v));
}
}
}
}
int main(void)
{
int n,r,i,a,b,c;
while (~scanf("%d%d",&n,&r))
{
init();
for (i=0; i<r; ++i)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
spfa(n);
S.g=0;
S.h=d[1];
S.cur=1;
S.f=S.g+S.h;
int second_dx=d[1];
q.push(S);
while (!q.empty())
{
info now=q.top();
q.pop();
if(now.cur==n)
{
if(second_dx!=now.f)
{
second_dx=now.f;
break;
}
}
for (i=head[now.cur]; ~i; i=E[i].pre)
{
info v;
v.cur=E[i].to;
v.g=now.g+E[i].dx;
v.h=d[v.cur];
v.f=v.g+v.h;
q.push(v);
}
}
printf("%d\n",second_dx);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  A star