您的位置:首页 > 其它

杭电OJ1062-Text Reverse

2016-08-09 11:18 337 查看
Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3

olleh !dlrow

m'I morf .udh

I ekil .mca

Sample Output

hello world!

I'm from hdu.

I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

代码是讨论版找的:

#include <iostream>
#include<string>
#include <algorithm>
using namespace std;
int main()
{
string str;
int begin,j,n;
while (cin>>n)
{
getchar();
while (n--)
{
getline(cin,str);
j = 0;
begin = 0;
while(str.find(' ',j)!=string::npos)
{
reverse(str.begin()+j,str.begin()+str.find(' ',j));
j = str.find(' ',j)+1;
}
reverse(str.begin()+j,str.end());
cout<<str<<endl;
}

}
return 0;
}


会用string的一些函数就会很方便。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: