您的位置:首页 > 其它

博弈______Euclid's Game( poj 2348 )

2016-08-09 10:26 363 查看
Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then
Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with
(25,7): 
25 7

11 7

4 7

4 3

1 3

1 0


an Stan wins.
Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12
15 24
0 0

Sample Output
Stan wins
Ollie wins


题意:

有两个数字,两个人轮流进行操作,操作为:将大数减去小数的整数倍。最先使得其中一个数变为0的胜利。

分析:

对于状态(a,b)显然是和(b,a)等效。所以我们假定(a,b)中b>=a.

对于状态(a,b)。我们可以知道可以由(a,b+a)状态一步到达。那么(a,b)和(a,b+a)肯定一个是必胜状态,一个是必败状态。因为(a,b)和(a,a+b)也可以由(a,b+2a)状态一步到达.所以(a,b+2a)一定是必胜状态。(原因可以看博弈图中的N点P点推导)

所以如果对于(a,b)状态:如果有 a == b 或者 b >= 2*a  一定是先手必赢。

如果对于 a < b < 2*a 则一定有(a,b)  的下一状态为(b-a,a) 然后继续执行上述判断流程。

代码:

#include<stdio.h>
#include<string.h>
typedef long long ll;
int main()
{
ll a,b;
while(scanf("%I64d%I64d",&a,&b)!=EOF)
{
if(a == 0 && b == 0) break;
if(a>b) a^=b^=a^=b;
int flag = 0;
while(a != b && b < 2*a)
{
flag = !flag;
b -= a;
if(a>b) a^=b^=a^=b;
}
if(flag)
printf("Ollie wins\n");
else
printf("Stan wins\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 2348 博弈