您的位置:首页 > 其它

POJ:1745 Divisibility(思维+动态规划DP)

2016-08-09 00:38 337 查看
Divisibility

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11509Accepted: 4124
Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are
eight possible expressions: 17 + 5 + -21 + 15 = 16

17 + 5 + -21 - 15 = -14

17 + 5 - -21 + 15 = 58

17 + 5 - -21 - 15 = 28

17 - 5 + -21 + 15 = 6

17 - 5 + -21 - 15 = -24

17 - 5 - -21 + 15 = 48

17 - 5 - -21 - 15 = 18

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5.

You are to write a program that will determine divisibility of sequence of integers.

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.
Sample Input
4 7
17 5 -21 15

Sample Output
Divisible

Source
Northeastern Europe 1999
题目大意:给你一列整数,在整数间加‘ + ’ 或 ‘ - ‘,问最终能否有种情况将k整除。

解题思路:可以把结果mod k看作状态,这样虽然n个数有2^n-1种运算方式,但结果只有k种,所以只需枚举这k个数即可。

dp[i][j]表示 前i个数运算结果mod k是否存在余数j,转台转移方程:如果dp【i-1,j】为真,则将dp【i, (j+a[i])mod k)】和

dp【i, (j-a[i])mod k)】变为真,另外注意取模后结果为负的情况。

代码如下:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
int quyu(int x,int k)//整数取余
{
int r=x%k;
while(r<0)//防止负数取余。。
{
r=r+k;
}
return r;
}
int dp[10010][101];//dp[i][j]表示第i个数对k取余后结果为j的情况,如果有这种情况的话标记为1,没有的话标记为0
int a[10010];
int main()
{
int n,k;
while(scanf("%d%d",&n,&k)!=EOF)
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
dp[1][quyu(a[1],k)]=1;//初始化前键
for(int i=2;i<=n;i++)
{
for(int j=0;j<k;j++)//列举余数,因为k作为模,取余结果一定小于k
{
if(dp[i-1][j])
{
dp[i][quyu(j+a[i],k)]=1;
dp[i][quyu(j-a[i],k)]=1;
}
}
}
if(dp
[0])
{
printf("Divisible\n");
}
else
{
printf("Not divisible\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  思维 动态规划 dp