您的位置:首页 > 其它

HDU-2689-Sort it

2016-08-08 23:25 225 查看
Problem Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.

For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3

1 2 3

4

4 3 2 1

Sample Output

0

6

题意:一列无序数,通过将相邻两数进行交换,形成递增序列,问最少要交换几次。

题解:说白了,就是一个冒泡排序,求出冒泡排序过程中交换的次数就行。

#include<iostream>
using namespace std;
int main()
{
int a[1005];
int n;
while (scanf("%d", &n) != EOF)
{
for (int i = 1; i <= n; i++)
{
scanf("%d", &a[i]);
}
int sum = 0;
for (int i = n-1; i >= 1; i--)
{
for(int j=1;j<=i;j++)
if (a[j] > a[j + 1])
{
int t = a[j];
a[j] = a[j + 1];
a[j + 1] = t;
sum++;
}
}
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDU