您的位置:首页 > 其它

hdu 5800 计数dp

2016-08-08 22:58 330 查看

To My Girlfriend

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 929    Accepted Submission(s): 359


[align=left]Problem Description[/align]
Dear Guo

I never forget the moment I met with you.You carefully asked me: "I have a very difficult problem. Can you teach me?".I replied with a smile, "of course"."I have n items, their weight was a[i]",you said,"Let's define f(i,j,k,l,m) to be the number of the subset
of the weight of n items was m in total and has No.i and No.j items without No.k and No.l items.""And then," I asked.You said:"I want to know

∑i=1n∑j=1n∑k=1n∑l=1n∑m=1sf(i,j,k,l,m)(i,j,k,laredifferent)

Sincerely yours,

Liao
 

[align=left]Input[/align]
The first line of input contains an integer T(T≤15)
indicating the number of test cases.

Each case contains 2 integers n,
s
(4≤n≤1000,1≤s≤1000).
The next line contains n numbers: a1,a2,…,an
(1≤ai≤1000).

 

[align=left]Output[/align]
Each case print the only number — the number of her would modulo
109+7
(both Liao and Guo like the number).

 

[align=left]Sample Input[/align]

2
4 4
1 2 3 4
4 4
1 2 3 4

 

[align=left]Sample Output[/align]

8
8

               加维以便计数

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
const long long mod=1e9+7;
int dp[1005][3][3];
int num[1005];
int main()
{
int n,t,s;
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));
scanf("%d %d",&n,&s);
for(int i=1;i<=n;i++)
{
scanf("%d",&num[i]);
}
dp[0][0][0]=1;
for(int i=1;i<=n;i++)
{
for(int j=s;j>=num[i];j--)
{
for(int a=2;a>=0;a--)
{
for(int b=2;b>=0;b--)
{
dp[j][a][b]+=dp[j-num[i]][a][b];
dp[j][a][b]%=mod;
if(a!=0)
{
dp[j][a][b]+=dp[j-num[i]][a-1][b];
dp[j][a][b]%=mod;
}
if(b!=0)
{
dp[j][a][b]+=dp[j][a][b-1];
dp[j][a][b]%=mod;
}
// cout<<"i="<<i<<" j=="<<j<<" a=="<<a<<" b="<<b<<" value="<<dp[j][a][b]<<endl;
}
}
}
for(int j=num[i]-1;j>=0;j--)
{
for(int a=2;a>=0;a--)
{
for(int b=2;b>=0;b--)
{
if(b!=0)
{
dp[j][a][b]+=dp[j][a][b-1];
dp[j][a][b]%=mod;
}
// cout<<"i="<<i<<" j=="<<j<<" a=="<<a<<" b="<<b<<" value="<<dp[j][a][b]<<endl;
}
}
}
}
ll ans=0;
for(int i=1; i<=s; i++) ans = (ans + dp[i][2][2])%mod;
cout<<(ans*4)%mod<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp