您的位置:首页 > 其它

POJ 1745 / UVa 10036 Divisibility (同余定理,DP,经典题目)

2016-08-08 21:05 525 查看
题目链接:

POJ

http://poj.org/problem?id=1745

UVa OJ

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=977

注:两个OJ系统要求不同 ,UVa 需要键入测试组数,POJ 则没有。

Divisibility(poj)

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11474 Accepted: 4104
Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are
eight possible expressions: 17 + 5 + -21 + 15 = 16 

17 + 5 + -21 - 15 = -14 

17 + 5 - -21 + 15 = 58 

17 + 5 - -21 - 15 = 28 

17 - 5 + -21 + 15 = 6 

17 - 5 + -21 - 15 = -24 

17 - 5 - -21 + 15 = 48 

17 - 5 - -21 - 15 = 18 

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input
4 7
17 5 -21 15


Sample Output
Divisible


思路:

状态方程:dp[i][j] 第 i 个数被 k 取余后为 j 的正确状态。

dp[i - 1][j]=dp[i][(j + a) % k] = dp[i][(j - a + k) % k]


代码:POJ

#include<stdio.h>
#include<string.h>
const int MYDD=1e4+1103;

bool dp[MYDD][128];

int main() {
int n,k;
memset(dp,false,sizeof(dp));
scanf("%d%d",&n,&k);
for(int j=0; j<n; j++) {
int dd;
scanf("%d",&dd);
if(j==0) {
dp[0][(dd%k+k)%k]=true;
} else {
if(dd<0)
dd=-1*dd;
dd%=k;
for(int l=0; l<k; l++) {
if(dp[j-1][l])		dp[j][(l+dd)%k]=dp[j][(l-dd+k)%k]=true;
}
}
}

if(dp[n-1][0])		puts("Divisible");
else				puts("Not divisible");
return 0;
}


代码:UVa OJ

#include<stdio.h>
#include<string.h>
const int MYDD=1e4+1103;

bool dp[MYDD][128];

int main() {
int t;
scanf("%d",&t);
while(t--) {
int n,k;
memset(dp,false,sizeof(dp));
scanf("%d%d",&n,&k);
for(int j=0; j<n; j++) {
int dd;
scanf("%d",&dd);
if(j==0) {
dp[0][(dd%k+k)%k]=true;
} else {
if(dd<0)
dd=-1*dd;
dd%=k;
for(int l=0; l<k; l++) {
if(dp[j-1][l])		dp[j][(l+dd)%k]=dp[j][(l-dd+k)%k]=true;
}
}
}

if(dp[n-1][0])		puts("Divisible");
else				puts("Not divisible");
}
return 0;
}


后:

**********
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: