您的位置:首页 > 其它

POJ 2686 Traveling by Stagecoach(状压DP)

2016-08-08 20:48 423 查看
Traveling by Stagecoach

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2917 Accepted: 1072 Special Judge
Description

Once upon a time, there was a traveler. 

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him. 

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in
each of the tickets. Of course, with more horses, the coach runs faster. 

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets
should be taken into account. 

The following conditions are assumed. 
A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach. 

Only one ticket can be used for a coach ride between two cities directly connected by a road. 

Each ticket can be used only once. 

The time needed for a coach ride is the distance between two cities divided by the number of horses. 

The time needed for the coach change should be ignored.

Input

The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space). 

n m p a b 

t1 t2 ... tn 

x1 y1 z1 

x2 y2 z2 

... 

xp yp zp 

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space. 

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero. 

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m. 

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10. 

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100. 

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.
Output

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces. 

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that
the above accuracy condition is satisfied. 

If the traveler cannot reach the destination, the string "Impossible" should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter
of "Impossible" is in uppercase, while the other letters are in lowercase. 

Sample Input
3 4 3 1 4
3 1 2
1 2 10
2 3 30
3 4 20
2 4 4 2 1
3 1
2 3 3
1 3 3
4 1 2
4 2 5
2 4 3 4 1
5 5
1 2 10
2 3 10
3 4 10
1 2 0 1 2
1
8 5 10 1 5
2 7 1 8 4 5 6 3
1 2 5
2 3 4
3 4 7
4 5 3
1 3 25
2 4 23
3 5 22
1 4 45
2 5 51
1 5 99
0 0 0 0 0

Sample Output
30.000
3.667
Impossible
Impossible
2.856

Hint

Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable. 

30.0

3.66667

Impossible

Impossible

2.85595


Source

Japan 2005 Domestic

/* POJ 2686
大意是有一个人从城市a要到城市b(点数<=30)
一共有m个城市 p条双向的路
然后有n个马车票,任意相邻的两个城市走的话要消耗掉一个马车票。
每个马车票上有个速率值, 边长度/速率就是花的时间。
问最后这个人花费的最短时间是多少

dp[S][v] 代表 (当前剩余票的状态)集合S时 从a走到v花费的最小时间
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
const int maxn = 1e5 + 5;
typedef pair<int, int> P;

double dp[1<<10][35];
int t[10];
vector<P>G[35];
int main(void)
{
// freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
int n, m, p, a, b, i, j, k, S, u, v, w;
double ans;
while (cin >> n >> m >> p >> a >> b && (n||m||p||a||b))
{
for (i = 0; i <= m; i++) G[i].clear();
for (i = 0; i < n; i++)
scanf("%d", &t[i]);
for (i = 0; i < p; i++){
scanf("%d %d %d", &u, &v, &w);
G[u].push_back(make_pair(v, w));
G[v].push_back(make_pair(u, w));
}
// memset(dp, INF, sizeof(dp)); // double类型初始化会错
for(i = 0; i < (1<<n); i++)
for(j = 0; j < 33; j++)
dp[i][j] = INF;
ans = INF;
dp[(1<<n)-1][a] = 0; // 初始化开始为0
for (S = (1<<n)-1; S >= 0; S--){
for (i = 0; i < n; i++){
if (!(S & (1<<i)))
continue;
for (u = 1; u <= m; u++){ // 相当于 拿着当前的票 把每条路都走一遍
for (j = 0; j < G[u].size(); j++){
v = G[u][j].first;
w = G[u][j].second;
dp[S^(1<<i)][v] = min(dp[S^(1<<i)][v], dp[S][u] + (w*1.0)/(1.0*t[i]));
}
}
}
ans = min(ans, dp[S][b]);
}
if (ans == INF)
puts("Impossible");
else printf("%.3f\n", ans);
}
4000
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: