您的位置:首页 > 其它

POJ Problem 1745 Divisibility 【dp】

2016-08-08 20:45 447 查看
Divisibility

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11461 Accepted: 4100
Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are
eight possible expressions: 17 + 5 + -21 + 15 = 16 

17 + 5 + -21 - 15 = -14 

17 + 5 - -21 + 15 = 58 

17 + 5 - -21 - 15 = 28 

17 - 5 + -21 + 15 = 6 

17 - 5 + -21 - 15 = -24 

17 - 5 - -21 + 15 = 48 

17 - 5 - -21 - 15 = 18 

We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 

The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.
Sample Input
4 7
17 5 -21 15

Sample Output
Divisible

Source

Northeastern Europe 1999

思路:

    用数组dp[i][j]判断后i个数mod k 的余数是不是k。状态转移方程为dp[i][abs(ar[j]-j)%k] = true(减去后面的数)和dp[i][abs(ar[j]+j)%k] = true(加上后面的数)。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#define MAXN 10005
using namespace std;
bool dp[MAXN][105];
int ar[MAXN];
int main() {
int t, n, a, b, k;
while (scanf("%d%d", &n, &k) != EOF) {
memset(dp, false, sizeof(dp));
for (int i = 1; i <= n; i++) {
scanf("%d", &ar[i]);
}
dp
[abs(ar
%k)] = true;
for (int i = n - 1; i >= 1; i--) {
for (int j = 0; j < k; j++) {
if (dp[i+1][j]) {
dp[i][abs(j+ar[i])%k] = true;
dp[i][abs(j-ar[i])%k] = true;
}
}
}
if (dp[1][0]) printf("Divisible\n");
else printf("Not divisible\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm dp poj