您的位置:首页 > 其它

hdu 1260 (Tickets)

2016-08-08 20:32 204 查看
  dp    Tickets


Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3258    Accepted Submission(s): 1614


Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.

A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.

Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full
of appreciation for your help.

 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

1) An integer K(1<=K<=2000) representing the total number of people;

2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;

3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 

Sample Input

2
2
20 25
40
1
8

 

Sample Output

08:00:40 am
08:00:08 am

 
题意:可以每次卖一张票用时a[ ],也可以同时卖两张票用时b[ ],问8点开始,最快什么时候能卖完。
题解:dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);注意输出,两位数输出可以用%02d.
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int main(){
int n,k,i,j,s,se,mi,h;
int a[2020];
int b[2020];
int dp[2020];
scanf ("%d",&n);
while (n--){
memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf ("%d",&k);
for (i=1;i<=k;i++){
scanf ("%d",&a[i]);
}
for (i=1;i<k;i++){
scanf ("%d",&b[i]);
}
dp[1]=a[1];
dp[2]=min(a[1]+a[2],b[1]);
for (i=3;i<=k;i++){
dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i-1]);

}
s=dp[k];
se=s%60;
mi=(s/60)%60;
h=(s/3600+8)%24;
printf ("%02d:%02d:%02d %s\n",h,mi,se,h>12?"pm":"am");//刚开始输出用了好多if语句处理0,真蠢
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: