您的位置:首页 > 其它

【HDU 杭电 1003 Max Sum】

2016-08-08 19:32 218 查看
Max Sum

Problem Description

Given a sequence a[1],a[2],a[3]……a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6

#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define  K 100011
#define INF 0x3f3f3f
using namespace std;
int  pa[K];
int  st[K];//当前的最大连续子序列的最大和
int main()
{
int i,j;
int T;
int n;
int ans;//最大连续子序列的和
int a,b;//子序列的首尾位置
int test=1;
int p=0;//最大连续子序列和的尾位置
scanf("%d",&T);
while(T--)
{
if(p)
printf("\n");
p=1;
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&pa[i]);
st[1]=pa[1];ans=pa[1];
b=1;
for(i=2;i<=n;i++)
{
st[i]=max(pa[i],pa[i]+st[i-1]); //当前连续子序列的最大和
if(st[i]>ans)//更新最大和
{
ans=st[i];
b=i;
}
}
a=b;
for(i=b;i>=1;i--)//求首位置
{
if(st[i]>=0)
a=i;
else
break;
}
printf("Case %d:\n",test++);
printf("%d %d %d\n",ans,a,b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电