您的位置:首页 > 其它

Brackets(区间dp)

2016-08-08 18:22 281 查看

Brackets

Time Limit: 1000ms
Memory Limit: 65536KB
64-bit integer IO format: %lld      Java class name:
Main

Submit

Status

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

<code>(), [], (()), ()[], ()[()]

while the following character sequences are not:

<code>(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 …
an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of
s. That is, you wish to find the largest m such that for indices
i1, i2, …, im where 1 ≤
i1 < i2 < … < im ≤
n, ai1ai2 …
aim is a regular brackets sequence.

Given the initial sequence <code>([([]])], the longest regular brackets subsequence is <code>[([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters <code>(, <code>), <code>[, and <code>]; each input test will have length between 1 and 100, inclusive. The end-of-file is
marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6


NYOJ 15 括号匹配(二)(区间dp)只是要求反了一下。。。这里,dp[i][j] 代表从i到j的范围, 最大的括号匹配数。如果a[i]
== a[j] 那么,dp[i][j] = dp[i+1][j-1] + 2 ,然后,进行长度区间值更新。。

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[500][500];
int main()
{
char a[500];
while(cin >> a && a[0] != 'e'){
int len = strlen(a);
memset(dp, 0, sizeof(dp));
for(int l = 1; l < len; l++)
for(int i = 0; i < len - 1; i++){//线段长度递推
int j = i + l;
if((a[i]=='[' && a[j]==']') || (a[i]=='(' && a[j]==')'))
dp[i][j] = dp[i+1][j-1] + 2;
for(int k = i; k < j; k++)
dp[i][j] = max(dp[i][j], dp[i][k]+dp[k+1][j]);
}
cout << dp[0][len-1] << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: