您的位置:首页 > 其它

POJ 3077-Rounders

2016-08-08 17:39 375 查看
[align=center]Rounders[/align]

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7970 Accepted: 5156
Description
For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and
round it to the nearest thousand, and so on ...
Input
Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output
For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.
Sample Input
9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output
20
10
4
5
100
10000000
50000000
2000
500

题意:
输入数字把他变成里他最近的整10或者整100或整1000类推,例如15变成20,14变成10,99变成100,999变成1000

注意:
虽然是个水题但是首位是9的情况折腾了我好久,感觉我一定智障了
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int main()
{
int kase;
cin>>kase;
while(kase--)
{
string x;
cin>>x;

for(int i=x.length()-1;i>0;i--)  //第一位不变
{

if( '5'<=x[i] && x[i]<='9' )  //进位
{
x[i-1]++;
}

x[i]='0';  //两种情况都要变成0
}

if(x[0]>'9')  //当99的情况如果不处理会输出:0
{
cout<<1;
x[0]='0';
}
cout<<x<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: