您的位置:首页 > 其它

HDU/HDOJ 1260 Tickets(卖票问题,DP)

2016-08-08 17:30 295 查看


Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
65536/32768 K (Java/Others)
Total Submission(s): 3204    Accepted Submission(s): 1584


Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.

A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.

Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full
of appreciation for your help.

 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

1) An integer K(1<=K<=2000) representing the total number of people;

2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;

3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 

Sample Input

2
2
20 25
40
1
8

 

Sample Output

08:00:40 am
08:00:08 am

 

Source

浙江工业大学第四届大学生程序设计竞赛

题意:

一些人排队买票,又两个方案:1,自己单独买;2,和前一个人一块买。最后结果给定从早上八点卖票,最少持续到几点完成工作。

思路:

动态规划求解。看代码注释部分。

最多花费的时间是50000S,但是给定的时间可以达到11:59:59 pm。

代码:0MS 1520K

#include<stdio.h>
#include<string.h>
const int MYDD=2e4+1103;

int one[MYDD];//个人单独买票的时间
int two[MYDD];//和前面的那一位共同买票时间
int dp[MYDD];//dp[j]前 j 个人买票花费的总时间
int MIN(int x,int y) {
return x<y? x:y;
}

int main() {
int N;
scanf("%d",&N);
while(N--) {
int K;
scanf("%d",&K);
memset(dp,0,sizeof(dp));
for(int j=1; j<=K; j++)
scanf("%d",&one[j]);
for(int j=1; j<=K-1; j++)
scanf("%d",&two[j]);
dp[1]=one[1];//第一个人买票花费的时间
for(int j=2; j<=K; j++)//DP的规划方程
dp[j]=MIN(dp[j-1]+one[j],dp[j-2]+two[j-1]);
//前 j-1 个人买票花费的时间+第 j 个人单独买票时间,
// 前 j-2 个人买票花费的时间+第 j 个人和第 j-1 个人一起买票的时间

//		printf("%d\n",dp[K]);

int hh,mm,ss;
//		char time[2];
ss=dp[K];
mm=ss/60;
hh=mm/60;
ss=ss-mm*60;
mm=mm-hh*60;
if(hh>4) {
//			strcpy(time,"pm");
hh-=4;
printf("%02d:%02d:%02d pm\n",hh,mm,ss);
} else {
//			strcpy(time,"am");
printf("%02d:%02d:%02d am\n",hh+8,mm,ss);
}
}
return 0;
}


后:

**********************

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: