您的位置:首页 > 其它

Max Sum(最大连续子序列)

2016-08-08 15:44 253 查看
Max Sum
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

#include<iostream>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1000000],n,t,d[1000000];
int main()
{int k=1;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
d[1]=a[1];
for(int i=2;i<=n;i++)
{
if(d[i-1]<0)
d[i]=a[i];
else
d[i]=a[i]+d[i-1];
}
int max1=d[1];
int end=1;
for(int i=2;i<=n;i++)
{
if(max1<d[i])
{
max1=d[i];
end=i;
}
}
int r=0,f=end;
for(int i=end;i>=1;i--)
{
r+=a[i];
if(r==max1)
f=i;
}
printf("Case %d:\n%d %d %d\n",k++,max1,f,end);
if(t!=0)
puts("");
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: