您的位置:首页 > 大数据 > 人工智能

POJ 1363Rails (栈)

2016-08-07 19:50 218 查看
Rails

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 31568Accepted: 12283
DescriptionThere is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.



The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, …, N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, …, aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

InputThe input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, …, N. The last line of the block contains just 0.

The last block consists of just one line containing 0. OutputThe output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last “null” block of the input. Sample Input5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0Sample OutputYes
No

Yes
SourceCentral Europe 1997

这道题就是让你判断能否用1,2,3,–,n这n个数通过栈生成一个这n个数的其中一个排列。

我们可以通过栈来解决。
我们使用posa来表示我们想要得到的序列,现在已经得到的位置,posb表示开始的站台出去了多少个元素。
那么就只有几种情况:
1、当初始站台的元素和目标站台的元素一样,直接入栈然后出栈。
2、当栈中的栈顶元素与目标站台元素一样,直接出栈。
3、当初始站台的元素还有的话,就进栈了。
4、没办法了,输出No。

#include<cstdio>

const int maxn=1e3+5;
int a[maxn];
int b[maxn];
int que[maxn];

int main(){
int n;
for(int i=0;i<maxn;++i){
b[i]=i+1;
}
while(scanf("%d",&n)&&n){
while(scanf("%d",&a[0])&&a[0]){
for(int i=1;i<n;++i){
scanf("%d",&a[i]);
}
int f=0;
int posa=0,posb=0;
bool J=true;
while(posa<n){
if(a[posa]==b[posb])++posa,++posb;
else if((f>0)&&(que[f-1]==a[posa]))++posa,--f;
else if(posb<n)que[f++]=b[posb++];
else{
J=false;break;
}
}
printf("%s\n",J?"Yes":"No");
}
putchar(10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: