您的位置:首页 > 产品设计 > UI/UE

poj 3080 Blue Jeans

2016-08-07 16:45 399 查看
Blue Jeans

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16531Accepted: 7342
Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences
of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output
no significant commonalities
AGATAC
CATCATCAT

Source

South Central USA 2006

这题就是

1、 最长公共串长度小于3不输出

2、 若出现等长的最长的子串,则输出字典序最小的串

幸好字符串的长度是60,一共有2-10个字符串

这样的数据给了我们暴力求解的条件

转载于来自 http://blog.csdn.net/stormdpzh/article/details/7390978

/*

涉及到string类的两个函数find和substr:

1、find函数

原型:size_t find ( const string& str, size_t pos = 0 ) const;

功能:查找子字符串第一次出现的位置。

参数说明:str为子字符串,pos为初始查找位置。

返回值:找到的话返回第一次出现的位置,否则返回string::npos

2、substr函数

原型:string substr ( size_t pos = 0, size_t n = npos ) const;

功能:获得子字符串。

参数说明:pos为起始位置(默认为0),n为结束位置(默认为npos)

返回值:子字符串

*/

#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <iostream>
using namespace std;
string ch[12];
string temp;
int main()
{
int n,m,i,j;
int t;
scanf("%d",&t);
while(t--)
{
string res("");
scanf("%d",&n);
for(i = 0;i < n; i++)
{
cin>>ch[i];
}
for(i = 3;i <= 60; i++)
{
for(j = 0;j <= 60-i; j++)
{
temp = ch[0].substr(j,i);     //意思是temp储存的是ch[0]字符串的从第j个字符开始一共有i位
int flag = 1;
for(int e = 1;e < n; e++)
{
if(ch[e].find(temp) == string::npos)    //查找其他字符有无相同的字符串
{
flag = 0;
break;
}
}
if(flag == 1 &&(temp.size() > res.size()|| temp.size() == res.size()&&temp < res)) //如果有的话以上条件,,,,,,
{
res = temp;
}
}
}
if(res != "")
{
cout << res << endl;
}
else
{
cout<< "no significant commonalities" << endl;
}
}
}


代码菜鸟,如有错误,请多包涵!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: