您的位置:首页 > 编程语言 > C语言/C++

POJ 1163 The Triangle

2016-08-06 23:56 288 查看
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

Source
IOI 1994
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

直接更新a[i][j]的值,可以少开一个数组~

#include<cstdio>

int a[106][106],n,maxx,l,r;

int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
for(int j=1;j<=i;j++)
{
scanf("%d",&a[i][j]);
l=(i-1>0)&&(j-1>0) ? a[i-1][j-1]:0;
r=(i-1>0) ? a[i-1][j]:0;
a[i][j]=(r>l ? r:l)+a[i][j];
if(maxx<a[i][j]) maxx=a[i][j];
}
printf("%d",maxx);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 动态规划