您的位置:首页 > 其它

POJ 1860 (反向bellman用法)

2016-08-06 18:07 295 查看
                                                                                                                     Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 26659 Accepted: 9850
Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing
in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected
in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations.

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain
6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 104.

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output
YES

Source
Northeastern Europe 2001, Northern Subregion

题意:

有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币

交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到(100 - 0.39) * 29.75 = 2963.3975 B币。

   问s币的金额经过交换最终得到的s币金额数能否增加

货币的交换是可以重复多次的,所以我们需要找出是否存在

  正权回路,且最后得到的s金额是增加的

怎么找正权回路呢?

  (正权回路:在这一回路上,顶点的权值能不断增加即能一直进行松弛)

  关键在于反向利用Bellman-Ford算法

单源最短路径算法,因为题目可能存在负边,所以用Bellman Ford算法,

原始Bellman Ford可以用来求负环,这题需要改进一下用来求正环

一种货币就是图上的一个点

一个“兑换点”就是图上两种货币之间的一个兑换环,相当于“兑换方式”M的个数,是双边

唯一值得注意的是权值,当拥有货币A的数量为V时,A到A的权值为K,即没有兑换

而A到B的权值为(V-Cab)*Rab

本题是“求最大路径”,之所以被归类为“求最小路径”是因为本题题恰恰

与bellman-Ford算法的松弛条件相反,求的是能无限松弛的最大正权路径,

但是依然能够利用bellman-Ford的思想去解题。

因此初始化d(S)=V   而源点到其他店的距离(权值)初始化为无穷小(0),

当s到其他某点的距离能不断变大时,说明存在最大路径
#include<cstdio>

#define M 110

double dist[M];     //记录兑换
int side;           //记录边数
int sande[M*2][2];      //起始点
double rate[M*2][2];    //利率和手续费

int bellman(int p,int n,double money)
{
for(int i = 1;i <= n; i++)
dist[i] = 0;  //反其道而行之,现在求得是最大解,并非最短路
dist[p] = money;

for(int i = 1;i < n; i++){

int flat = 0;               //判断正环的存在

for(int j = 0;j < side; j++){
int s = sande[j][0];    //起点
int e = sande[j][1];    //终点
if(dist[e] < (dist[s] - rate[j][1])*rate[j][0]){
flat = 1;
dist[e] = (dist[s] - rate[j][1])*rate[j][0];
}
}

if(!flat)
return 0;
}
for(int i = 0;i < side; i++)
if(dist[sande[i][1]] < (dist[sande[i][0]] - rate[i][1])*rate[i][0])
return 1;
return 0;
}

int main()
{
int n,m,p;
double money;    //钱的种类,兑换方式,m的个数,钱的数量
while(scanf("%d%d%d%lf",&n,&m,&p,&money) != EOF){

side = 0;
for(int i = 0;i < m; i++){
int s,e;
double r1,r2,r3,r4;
scanf("%d%d%lf%lf%lf%lf",&s,&e,&r1,&r2,&r3,&r4);    //减少长度
sande[side][0] = s;
sande[side][1] = e;
rate[side][0] = r1;
rate[side][1] = r2;
side++;
sande[side][0] = e;         //因为是双向的,所以每一种情况要有
sande[side][1] = s;
rate[side][0] = r3;
rate[side][1] = r4;
side++;
}

if(bellman(p,n,money))
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bellman