您的位置:首页 > 产品设计 > UI/UE

HDU 2817 A sequence of numbers (数学+快速幂)

2016-08-06 16:38 483 查看
Problem Description

Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers
in these sequences, and he needs your help.

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want
to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

Output
Output one line for each test case, that is, the K-th number module (%) 200907.

Sample Input
2
1 2 3 5
1 2 4 5

Sample Output
5
16

Source
2009 Multi-University Training Contest 1 - Host by TJU

题意: 

    给你数列的前三个数a、b、c,判断这个数列是等差数列还是等比数列,然后求数列的第K个值,,,最后对200907取模,

思路:

  先根据前三个数判断数列,再用等差或者等比数列公式求第k个值,,取模需要使用快速幂。。

以下AC代码:

#include<stdio.h>
#define mod 200907
long long QucikMod(long long a,long long b)
{
long long temp=1;
a=a%mod;
while(b>0)
{
if(b%2==1)
temp=(temp*a)%mod;
b=b/2;
a=(a*a)%mod;
}
return temp;
}
int main()
{
long long t,a,b,c,q,d,k,sum;
scanf("%I64d",&t);
while(t--)
{
scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k);
if(c-b==b-a)
{
d=b-a;
sum=(a%mod+(k-1)*d%mod)%mod;
}
else
{
q=b/a;
sum=a*QucikMod(q,k-1)%mod;
}
printf("%I64d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: