您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树的建立与遍历 ( sdut oj2136)

2016-08-06 16:20 495 查看

数据结构实验之二叉树的建立与遍历


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

 输入一个长度小于50个字符的字符串。

输出

输出共有4行:

第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,


示例输出

cbegdfa

cgefdba

3

5


提示

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

struct node
{
char data;
struct node *lchild, *rchild;
} *root;

int top;
int s = 0;
char st[55];
struct node *creat()
{
struct node *root;
if(st[top++] == ',')
root = NULL;
else
{
root = (struct node*)malloc(sizeof(struct node));
root->data = st[top-1];
root->lchild = creat();
root->rchild = creat();
}
return root;
}
void zhongxu(struct node *root)
{
if(root)
{
zhongxu(root->lchild);
printf("%c", root->data);
zhongxu(root->rchild);
}
}
void houxu(struct node *root)
{
if(root)
{
houxu(root->lchild);
houxu(root->rchild);
printf("%c", root->data);
}
}
int PreOrder(struct node *root)
{
if(root)
{
if(!root->lchild&&!root->rchild)
{
s++;
}
PreOrder(root->lchild);
PreOrder(root->rchild);
}
return s;
}
int Max;
void depth(struct node *root, int ans)
{
if(root)
{
if(ans > Max)
Max = ans;
depth(root->lchild, ans+1);
depth(root->rchild, ans+1);
}
}
int main()
{
while(~scanf("%s", st))
{
int d;
top = 0;
root = creat();
zhongxu(root);
printf("\n");
houxu(root);
printf("\n");
d = PreOrder(root);
printf("%d\n", d);
Max=0;
depth(root,1);
printf("%d\n", Max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 二叉树