您的位置:首页 > 其它

POJ 2823 Sliding Window(单调队列模板题)

2016-08-06 15:37 369 查看
http://poj.org/problem?id=2823

Sliding Window

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:

The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3

1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3

3 3 5 5 6 7

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 1e6 + 100;
int arr
,n,k;
int pos
,que
,MAX
,MIN
;
void get_max()
{
int head = 1, tail = 0 ;
for(int i = 1; i<=n ;i++)
{
while(head<=tail && que[tail]<=arr[i]) --tail;
que[++tail] = arr[i];
pos[tail] = i;

if(i<k) continue;

while( pos[head] < i-k+1 ) head++;
MAX[i-k+1] = que[head];
}
for(int i=1;i<=n-k+1;i++)
printf("%d%c",MAX[i],i==n-k+1?'\n':' ');
}
void get_min()
{
int head = 1, tail = 0;
for(int i = 1; i<=n ; i++)
{
while(head<=tail && que[tail]>=arr[i]) --tail;
que[++tail] = arr[i];
pos[tail] = i;

if(i<k) continue;

while(pos[head] < i-k+1 ) head++;
MIN[i-k+1] = que[head];
}
for(int i=1;i<=n-k+1;i++)
printf("%d%c",MIN[i],i==n-k+1?'\n':' ');
}
int main()
{
scanf("%d%d",&n,&k);
for(int i=1;i<=n;i++) scanf("%d",&arr[i]);
get_min();
get_max();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj