您的位置:首页 > 其它

POJ 3624 Charm Bracelet

2016-08-06 15:23 204 查看
Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6

1 4

2 6

3 12

2 7

Sample Output

23

Source

USACO 2007 December Silver

简单背包,但是…数据范围二维数组开不起,所以要用一维数组。

#include <iostream>
#include <cstdio>
using namespace std;

struct DC
{
int w, d;
}p[3450];
int dp[13300];

int main()
{
int n, m;
scanf("%d%d", &n, &m);
for(int i = 1; i <= n; i++)
scanf("%d%d", &p[i].w, &p[i].d);
for(int i = 1; i <= n; i++)
for(int j = m; j >= p[i].w; j--)
dp[j] = max(dp[j - p[i].w] + p[i].d, dp[j]);
cout<<dp[m];
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  DP