您的位置:首页 > 其它

hdu1013 Digital Roots

2016-08-06 11:00 393 查看
Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 
Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 
Output

For each integer in the input, output its digital root on a separate line of the output.

 
Sample Input

24
39
0


 
Sample Output

6
3


 
最开始的时候,我的代码是这样的:
#include<iostream>
using namespace std;

int ans(int n)
{
int sum=0;
int temp;
while(n>0)
{
temp = n%10;
n = n/10;
sum += temp;
}
if(sum>9)
{
ans(sum);
}
else
{
return sum;
}
}

int main()
{
int n;
while(cin>>n)
{
if(0==n)
{
break;
}
cout<<ans(n)<<endl;
}
return 0;
}
但是上面这个代码提交之后却wrong answer了,仔细想了想才意识到问题:输入的数字可能会巨大。于是在上面这个代码的基础上加入了string类型。一下是ac的代码:
#include<iostream>
#include<string>
#include<cstring>
#include<cstdlib>
using namespace std;

int ans(int n)
{
int sum=0;
int temp;
while(n>0)
{
temp = n%10;
n = n/10;
sum += temp;
}
if(sum>9)
{
ans(sum);
}
else
{
return sum;
}
}

int main()
{
string s;
while(cin>>s)
{
int len = s.length();
if(1==len&&s[0]=='0')
{
break;
}

int num = 0;
for(int i=0;i<len;i++)
{
num += static_cast<int>(s[i]-'0');
}

cout<<ans(num)<<endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: