您的位置:首页 > 产品设计 > UI/UE

hdu1503 Advanced Fruits (LCS)

2016-08-05 17:09 183 查看
Problem Description

The company “21st Century Fruits” has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn’t work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.

A big topic of discussion inside the company is “How should the new creations be called?” A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn’t sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, “applear” contains “apple” and “pear” (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a “boysecranberry” or a “craboysenberry”, for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.

Sample Input

apple peach

ananas banana

pear peach

Sample Output

appleach

bananas

pearch

题意:求给出两个字符串除去相同的字符,组合成最短的字符串;

思路:LCS,在用LCS的时候我们还有标记此点指向上次在哪个地方,我们在输出的时候用回溯从末端开始查询输出就行;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[105],b[105];
int dp[105][105],mark[105][105];
void dfs(int la,int lb)
{
if(!la&&!lb)
return;
if(mark[la][lb]==0)
{
dfs(la-1,lb-1);
printf("%c",a[la-1]);
}
else if(mark[la][lb]==-1)
{
dfs(la,lb-1);
printf("%c",b[lb-1]);
}
else
{
dfs(la-1,lb);
printf("%c",a[la-1]);
}
}
int main()
{
while(~scanf("%s%s",a,b))
{
int la=strlen(a);
int lb=strlen(b);
memset(mark,0,sizeof(mark));
memset(dp,0,sizeof(dp));
for(int i=0;i<=la;i++)
mark[i][0]=1;
for(int j=0;j<=lb;j++)
mark[0][j]=-1;
for(int i=1;i<=la;i++)
for(int j=1;j<=lb;j++)
{
if(a[i-1]==b[j-1])
{
dp[i][j]=dp[i-1][j-1]+1;
mark[i][j]=0;
}
else if(dp[i][j-1]>=dp[i-1][j])
{
dp[i][j]=dp[i][j-1];
mark[i][j]=-1;
}
else
{
dp[i][j]=dp[i-1][j];
mark[i][j]=1;
}
}
dfs(la,lb);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: