您的位置:首页 > 其它

BFS_2

2016-08-05 13:15 316 查看
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is
a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value
of n, any one of them is acceptable.

Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


题目意思是给了你一个数,让你找出一个只有0和1组成的数(最小)来整除它。

注意虽然题目说答案可能有100位数,但是 long long 也可以过的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
int n;
void bfs()
{
queue<long long> q;
while(!q.empty())
q.pop();
q.push(1);
while(1)
{
long long tmp=q.front();
if(tmp%n==0)
{
cout<<tmp<<'\n';
return;
}
q.pop();
q.push(tmp*10);
q.push(tmp*10+1);
}
}
int main()
{
while(scanf("%d",&n),n)
bfs();
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: