您的位置:首页 > 其它

POJ-1611-The Suspects

2016-08-05 11:34 344 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 33032 Accepted: 16009
Description

Severe acute respiratory syndrome (SARS), an atypical(非典型的) pneumonia(肺炎) of
unknown aetiology(病因学), was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy
is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


并查集,没什么好说的,编号从0到n-1,最后输出和0号同组的人数

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int MAXN= 30001;
int n, m;
int pre[MAXN];
int Find(int x)
{
while(pre[x]!=x)x = pre[x];
return x;
}
int main()
{
int k,a,b;
while(~scanf("%d%d",&n,&m)&&(n||m))
{
for(int i = 0;i<n;++i)
pre[i] = i;
while(m--)
{
scanf("%d",&k);
if(k)scanf("%d",&a);
while(--k>0)
{
scanf("%d",&b);
if(Find(a)!=Find(b))
pre[Find(b)] = Find(a);
}
}
int num = 0;
for(int i = 0;i<n;++i)
if(Find(i)==Find(0))num++;
printf("%d\n",num);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: