您的位置:首页 > 其它

【POJ】1451 - T9(动态字典树 & dfs & STL)

2016-08-05 10:00 435 查看
点击打开题目

T9

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3806 Accepted: 1362
Description

Background 

A while ago it was quite cumbersome to create a message for the Short Message Service (SMS) on a mobile phone. This was because you only have nine keys and the alphabet has more than nine letters, so most characters could only be entered by pressing one key
several times. For example, if you wanted to type "hello" you had to press key 4 twice, key 3 twice, key 5 three times, again key 5 three times, and finally key 6 three times. This procedure is very tedious and keeps many people from using the Short Message
Service. 

This led manufacturers of mobile phones to try and find an easier way to enter text on a mobile phone. The solution they developed is called T9 text input. The "9" in the name means that you can enter almost arbitrary words with just nine keys and without pressing
them more than once per character. The idea of the solution is that you simply start typing the keys without repetition, and the software uses a built-in dictionary to look for the "most probable" word matching the input. For example, to enter "hello" you
simply press keys 4, 3, 5, 5, and 6 once. Of course, this could also be the input for the word "gdjjm", but since this is no sensible English word, it can safely be ignored. By ruling out all other "improbable" solutions and only taking proper English words
into account, this method can speed up writing of short messages considerably. Of course, if the word is not in the dictionary (like a name) then it has to be typed in manually using key repetition again. 


 

Figure 8: The Number-keys of a mobile phone.

More precisely, with every character typed, the phone will show the most probable combination of characters it has found up to that point. Let us assume that the phone knows about the words "idea" and "hello", with "idea" occurring more often. Pressing the
keys 4, 3, 5, 5, and 6, one after the other, the phone offers you "i", "id", then switches to "hel", "hell", and finally shows "hello". 

Problem 

Write an implementation of the T9 text input which offers the most probable character combination after every keystroke. The probability of a character combination is defined to be the sum of the probabilities of all words in the dictionary that begin with
this character combination. For example, if the dictionary contains three words "hell", "hello", and "hellfire", the probability of the character combination "hell" is the sum of the probabilities of these words. If some combinations have the same probability,
your program is to select the first one in alphabetic order. The user should also be able to type the beginning of words. For example, if the word "hello" is in the dictionary, the user can also enter the word "he" by pressing the keys 4 and 3 even if this
word is not listed in the dictionary.
Input

The first line contains the number of scenarios. 

Each scenario begins with a line containing the number w of distinct words in the dictionary (0<=w<=1000). These words are iven in the next w lines in ascending alphabetic order. Every line starts with the word which is a sequence of lowercase letters from
the alphabet without whitespace, followed by a space and an integer p, 1<=p<=100, representing the probability of that word. No word will contain more than 100 letters. 

Following the dictionary, there is a line containing a single integer m. Next follow m lines, each consisting of a sequence of at most 100 decimal digits 2�, followed by a single 1 meaning "next word".
Output

The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. 

For every number sequence s of the scenario, print one line for every keystroke stored in s, except for the 1 at the end. In this line, print the most probable word prefix defined by the probabilities in the dictionary and the T9 selection rules explained above.
Whenever none of the words in the dictionary match the given number sequence, print "MANUALLY" instead of a prefix. 

Terminate the output for every number sequence with a blank line, and print an additional blank line at the end of every scenario.
Sample Input
2
5
hell 3
hello 4
idea 8
next 8
super 3
2
435561
43321
7
another 5
contest 6
follow 3
give 13
integer 6
new 14
program 4
5
77647261
6391
4681
26684371
77771

Sample Output
Scenario #1:
i
id
hel
hell
hello

i
id
ide
idea

Scenario #2:
p
pr
pro
prog
progr
progra
program

n
ne
new

g
in
int

c
co
con
cont
anoth
anothe
another

p
pr
MANUALLY
MANUALLY

Source

Northwestern Europe 2001

啊一遍A过的好开心,这种题输出的时候看着确实好美啊。

题目要求按词频输出,就是说按到这个键的时候,输出最大的词频的字符串,这里用一下dfs就行了。

创建字典树的时候,我们把每个字符的词频加到树上。

然后碰到询问的时候,从0~ |ask| - 1 依次去搜索就行了。

最后没有释放内存也只不过用了不到1000k,时间也只有16ms,确实高效。

记录单词的时候用了STL - string 的内容,很好用的。

代码如下:

#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define idx(x) (x-'a')
char ch[8][5] = {{"abc"},{"def"},{"ghi"},{"jkl"},{"mno"},{"pqrs"},{"tuv"},{"wxyz"}};
string ans,temp;
int maxx;		//最大词频
char ask[111];
struct Trie
{
Trie *next[26];
int v;		//词频
void clear()
{
v = 0;
for (int i = 0 ; i < 26 ; i++)
next[i] = NULL;
}
};
Trie *root;
void insert(char *s,int num)
{
int l = strlen(s);
Trie *p = root , *q;
for (int i = 0 ; i < l ; i++)
{
int id = idx(s[i]);
if (p->next[id] == NULL)
{
q = (Trie *)malloc(sizeof(Trie));
q->clear();
p->next[id] = q;
}
p = p->next[id];
p->v += num;
}
}
void dfs(int pos , int goal , Trie *p)
{
if (pos == goal + 1)		//搜到最后比较词频
{
if (p->v > maxx)
{
maxx = p->v;
ans = temp;
}
return;
}
int num = ask[pos] - '2';
int l = strlen(ch[num]);		//该按键有几个字符
for (int i = 0 ; i < l ; i++)
{
if (p->next[ch[num][i] - 'a'] != NULL)
{
temp += ch[num][i];
dfs(pos+1,goal,p->next[ch[num][i]-'a']);
temp = temp.substr(0,temp.length()-1);
}
}
}
int main()
{
int u;
int n;
int Case = 1;
char t[111];
int num;		//词频
scanf ("%d",&u);
while (u--)
{
root = (Trie *)malloc(sizeof(Trie));
root->clear();
scanf ("%d",&n);
for (int i = 0 ; i < n ; i++)
{
scanf ("%s %d",t,&num);
insert(t,num);
}
int q;
scanf ("%d",&q);
printf ("Scenario #%d:\n",Case++);
while (q--)
{
scanf ("%s",ask);
int l = strlen(ask) - 1;		//最后一位1不用扫
for (int i = 0 ; i < l ; i++)
{
ans = "";
temp = "";
maxx = 0;		//最大词频
dfs(0,i,root);
if (maxx == 0)
printf ("MANUALLY\n");
else
printf ("%s\n",ans.c_str());
}
printf ("\n");
}
printf ("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: