您的位置:首页 > 其它

POJ-1562-Oil Deposits(DFS)

2016-08-05 09:12 357 查看
Oil Deposits

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 16233 Accepted: 8738

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either
*', representing the absence of oil, or
@’, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

@@*

@

@@*

1 8

@@**@*

5 5

**@

@@@

@*@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

题意:给出地图,@代表油井,上下左右对角线相连的油井算作一块油田,输出地图中有多少块油田

思路:对每个油井深搜标记与它相连的油田为陆地

代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<string.h>
using namespace std;
const int maxn=105;
int M,N;
char map[maxn][maxn];
int dis[8][2]= {{1,0},{-1,0},{0,1},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};
void DFS(int x,int y)
{
if(x>=0&&x<M&&y>=0&&y<N&&map[x][y]=='@')
{
map[x][y]='*';
for(int i=0; i<8; i++)
DFS(x+dis[i][0],y+dis[i][1]);
}
}
int main()
{
while(1)
{
scanf("%d%d",&M,&N);
if(M==0)
break;
for(int i=0; i<M; i++)
scanf("%s",map[i]);
int num=0;
for(int i=0; i<M; i++)
{
for(int j=0; j<N; j++)
{
if(map[i][j]=='@')
{
num++;
DFS(i,j);
}
}
}
printf("%d\n",num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: