您的位置:首页 > 其它

hdu 2141 Can you find it?(二分)

2016-08-04 19:27 330 查看

Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 24218 Accepted Submission(s): 6127


[align=left]Problem Description[/align]
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

[align=left]Input[/align]
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent
the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

[align=left]Output[/align]
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

[align=left]Sample Input[/align]

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10


[align=left]Sample Output[/align]

Case 1:
NO
YES
NO


题意:

给出一个等式Ai+Bj+Ck = X,并且给出A、B、C的取值, 以及有S个X,查询在A、B、C中是否有值满足X关于等式成立.

思路:

我们需要枚举一个变量,那么,必须预处理出其中两个数的所有的和。这里,我预处理出A和B所有的可能,并且排序,枚举C,二分查找预处理出来的和。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;
int L[510], N[510], M[510];
long long arr[250010];

int main(){
int l, n, m, S, X, tot=0;
while(cin>>l>>n>>m){
for(int i=0; i<l; i++)
cin>>L[i];
for(int i=0; i<n; i++)
cin>>N[i];
for(int i=0; i<m; i++)
cin>>M[i];

int cnt = 0;
for(int i=0; i<l; i++)
for(int j=0; j<n; j++)
arr[cnt++] = L[i]+N[j];

sort(arr, arr+cnt);

cout<<"Case "<<++tot<<":"<<endl;

cin>>S;
while(S--){
cin>>X;
int flag = -1;
for(int i=0; i<m&&flag!=1; i++){
int low = 0;
int high = cnt-1;
while(low<=high){
int mid = (low+high)/2;
if(M[i]+arr[mid]==X){
flag = 1;
break;
}
else if(M[i]+arr[mid]<X)
low = mid+1;
else
high = mid-1;
}
}
if(flag==1)
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: