您的位置:首页 > 其它

规律题_1

2016-08-04 16:52 309 查看
Description

N children standing in circle who are numbered 1 through N clockwise are waiting their candies. Their teacher distributes the candies by in the following way:

First the teacher gives child No.1 and No.2 a candy each. Then he walks clockwise along the circle, skipping one child (child No.3) and giving the next one (child No.4) a candy. And then he goes on his walk, skipping two children (child No.5 and No.6) and
giving the next one (child No.7) a candy. And so on.

Now you have to tell the teacher whether all the children will get at least one candy?

Input

The input consists of several data sets, each containing a positive integer N (2 ≤ N ≤ 1,000,000,000).

Output

For each data set the output should be either "YES" or "NO".

Sample Input

2
3
4


Sample Output

YES
NO
YES


属于规律题,可以尝试打表发现规律,当n是2的指数幂时YES
<pre name="code" class="cpp">#include<iostream>
#include<cstring>
using namespace std;

int main()
{
int n;
while(cin>>n)
{
while(n%2==0){
n=n/2;
}
if(n==1) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: