您的位置:首页 > 其它

Floyd-Warshall算法的应用——杭电OJ 1217 Arbitrage

2016-08-04 16:10 645 查看


Arbitrage

Problem Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French
franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

 

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear.
The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency.
Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 

 

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 

 

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

 

Sample Output

Case 1: Yes
Case 2: No

 

#include <stdio.h>
#include <string.h>
int n, m;
char currency[40][50];
double map[40][40];
/*num函数给输入的货币编号*/
int num(char c[]);
int main()
{
//freopen("data.in", "r", stdin);
int i, k, j, kase = 0, flag;
double rate;
char c1[50], c2[50];
while (scanf("%d", &n) != EOF && n) {
for (i = 1; i <= n; i++)
scanf("%s", currency[i]);
/*初始化二维数组map*/
memset(map, 0, sizeof(map));
for (i = 1; i <=n; i++)
map[i][i] = 1;
/*对输入的货币编号,并存入map中*/
scanf("%d", &m);
while (m--) {
scanf("%s %lf %s", c1, &rate, c2);
map[num(c1)][num(c2)] = rate;
}
/*Floyd-Warshall算法核心部分*/
for (k = 1; k <= n; k++)
for (i = 1; i <= n; i++)
for (j = 1; j <= n; j++)
if (map[i][j] < map[i][k] * map[k][j]) /*根据题意,有所改动*/
map[i][j] = map[i][k] * map[k][j];
/*判断部分*/
flag = 0;
for (i = 1; i <= n; i++)
if (map[i][i] > 1) {
flag =1;
break;
}
if (flag)
printf("Case %d: Yes\n", ++kase);
else
printf("Case %d: No\n", ++kase);
}

return 0;
}

int num(char c[])
{
int i;
for (i = 1; i <= n; i++)
if (strcmp(c, currency[i]) == 0)
return i;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: