您的位置:首页 > 其它

HDU 1303 Doubles

2016-08-04 15:15 267 查看

Doubles

[align=left]Problem Description[/align]
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list.
You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

 

[align=left]Input[/align]
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated
with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

 

[align=left]Output[/align]
The output will consist of one line per input list, containing a count of the items that are double some other item.

 

[align=left]Sample Input[/align]

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

 

[align=left]Sample Output[/align]

3
2
0

题意:一行数中找到有多少个二倍关系,给的数字范围是0到99。

建一个bool型数组,范围100出头就行,标记所有出现过的数,从头开始找2倍关系。

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
bool a[102];
int n;
while(~scanf("%d",&n))
{
if(n==-1)
break;
memset(a,0,sizeof(a));
a
=1;
if(n)
while(scanf("%d",&n)&&n)
a
=1;
int i,sum=0;
for(i=1;i<50;i++)
{
if(a[i]&&a[i*2])
{
sum++;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDU