您的位置:首页 > 运维架构

1114. Family Property (25)

2016-08-04 14:05 344 查看
This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their
real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person;
Father and Mother are the ID's of this person's parents (if a parent has passed away,
-1 will be given instead); k (0<=k<=5) is the number of children of this person;
Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and
Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members;
AVG_sets is the average number of sets of their real estate; and
AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000


给出n个人的信息,要求根据信息将他们分成若干个家庭,输出每个家庭的id最小的成员的id,家庭人数,人均拥有的房产数和人均房产面积。将有联系的人分到一个家庭,故输入的时候,对于每个人,用set表示联系人集合,保存和该人有联系的人,同时也要更新对方的联系人集合,即将当前人加入到对方的联系人集合。然后用dfs找出每个家庭的所有人,并且得到想要的家庭信息。然后优先按照家庭人均房产面积从大到小排序,其次按照id从小到大排序。最后输出结果即可。

代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <set>
using namespace std;

struct people
{
set<int>rset;
int estate;
int area;
people():estate(0),area(0){}
};

people ps[10001];
bool isvis[10001];

void dfs(int id,int &min_id,int &num,int &sum_estate,int &sum_area)
{
if(id==-1||isvis[id]) return;
min_id=min(min_id,id);
num++;
sum_estate+=ps[id].estate;
sum_area+=ps[id].area;
isvis[id]=true;

set<int>::iterator it;
for(it=ps[id].rset.begin();it!=ps[id].rset.end();it++)
{
dfs(*it,min_id,num,sum_estate,sum_area);
}
}

struct res_data
{
int id;
int num;
double avg_estate;
double avg_area;
res_data(int i,int n,double ae,double aa):id(i),num(n),avg_estate(ae),avg_area(aa){}
};

bool cmp(const res_data &r1,const res_data &r2)
{
if(r1.avg_area!=r2.avg_area) return r1.avg_area>r2.avg_area;
else return r1.id<r2.id;
}

int main()
{
int n;
cin>>n;
memset(isvis,false,sizeof(isvis));
vector<int>ids(n);
for(int i=0;i<n;i++)
{
int id,f,m,k;
cin>>id>>f>>m>>k;
ids[i]=id;
if(f!=-1)
{
ps[id].rset.insert(f);
ps[f].rset.insert(id);
}
if(m!=-1)
{
ps[id].rset.insert(m);
ps[m].rset.insert(id);
}
for(int j=0;j<k;j++)
{
int c;
cin>>c;
ps[id].rset.insert(c);
ps[c].rset.insert(id);
}
cin>>ps[id].estate>>ps[id].area;
}

vector<res_data>res;
for(int i=0;i<n;i++)
{
if(isvis[ids[i]]) continue;
int min_id=1<<30,num=0,sum_estate=0,sum_area=0;
dfs(ids[i],min_id,num,sum_estate,sum_area);
res.push_back(res_data(min_id,num,double(sum_estate*1.0/num),double(sum_area*1.0/num)));
}
sort(res.begin(),res.end(),cmp);
cout<<res.size()<<endl;
for(int i=0;i<res.size();i++)
{
printf("%04d %d %.3f %.3f\n",res[i].id,res[i].num,res[i].avg_estate,res[i].avg_area);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs sort