您的位置:首页 > 其它

hdu2121 Ice_cream’s world II (最小树形图模板)

2016-08-04 13:31 267 查看

Ice_cream’s world II

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4534 Accepted Submission(s): 1104


[align=left]Problem Description[/align] After awarded lands to ACMers, the queen want to choose a city be her capital. This is an important event in ice_cream world, and it also a very difficult problem, because the world have N cities and M roads, every road was directed. Wiskey is a chief engineer in ice_cream world. The queen asked Wiskey must find a suitable location to establish the capital, beautify the roads which let capital can visit each city and the project’s cost as less as better. If Wiskey can’t fulfill the queen’s require, he will be punishing.
[align=left]Input[/align] Every case have two integers N and M (N<=1000, M<=10000), the cities numbered 0…N-1, following M lines, each line contain three integers S, T and C, meaning from S to T have a road will cost C.
[align=left]Output[/align] If no location satisfy the queen’s require, you must be output “impossible”, otherwise, print the minimum cost in this project and suitable city’s number. May be exist many suitable cities, choose the minimum number city. After every case print one blank.

[align=left]Sample Input[/align]
3 1

0 1 1


4 4

0 1 10

0 2 10

1 3 20

2 3 30

[align=left]Sample Output[/align]
impossible


40 0

这是一种最小树形图,是无根的,我们要自己构造一个根。

这个根的构造方法就是这个根与其他结点的权值为(其他结点的权值总和再加上1)。然后计算出来的最小树形图的权值再减去(其他结点的权值总和再加上1)就是了。

#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
const int maxn=1005;

typedef long long LL;
const LL inf=0x7fffffff;
const LL infs=0x7;
struct node { //边的权和顶点
int u, v;
LL w;
} a[maxn * maxn];

int pre[maxn], id[maxn], used[maxn], n, m, pos;
LL in[maxn];//存最小入边权,pre[v]为该边的起点

LL Directed_MST(int root, int V, int E) {
LL ret = 0;//存最小树形图总权值
while(true) {
int i;
//1.找每个节点的最小入边
for( i = 0; i < V; ++i)
in[i] = inf;//初始化为无穷大
for( i = 0; i < E; ++i) { //遍历每条边
int u = a[i].u;
int v = a[i].v;
if(a[i].w < in[v] && u^v) { //说明顶点v有条权值较小的入边  记录之
pre[v] = u;//节点u指向v
in[v] = a[i].w;//最小入边
if(u == root)//这个点就是实际的起点
pos = i;
}
}
for( i = 0; i < V; ++i) { //判断是否存在最小树形图
if((i^root)&&in[i] == inf)
return -1;//除了根以外有点没有入边,则根无法到达它  说明它是独立的点 一定不能构成树形图
}
//2.找环
int cnt = 0;//记录环数
memset(id, -1, sizeof(id));
memset(used, -1, sizeof(used));
in[root] = 0;
for( i = 0; i < V; ++i) { //标记每个环//枚举每个点,搜索找环
ret += in[i];//记录权值
int v = i;
while(used[v] != i && id[v] == -1 && v != root) {
used[v] = i;
v = pre[v];
}
if(v != root && id[v] == -1) {//当找到环的时候缩点编号
for(int u = pre[v]; u != v; u = pre[u])
id[u] = cnt;//标记节点u为第几个环
id[v] = cnt++;
}
}
if(cnt == 0)
break; //无环//如果没有环结束程序
for( i = 0; i < V; ++i)//把余下的不在环里的点编号
if(id[i] == -1)
id[i] = cnt++;
//3.建立新图   缩点,重新标记
for( i = 0; i < E; ++i) {
int u = a[i].u;
int v = a[i].v;
a[i].u = id[u];
a[i].v = id[v];
if(id[u] != id[v])
a[i].w -= in[v];
}
V = cnt;
root = id[root];
}
return ret;
}
int main() {
int i;

while(scanf("%d%d", &n, &m) != EOF) {
LL sum = 0;
for( i = 0; i < m; ++i) {
scanf("%d%d%I64d", &a[i].u, &a[i].v, &a[i].w);
a[i].u++;
a[i].v++;
sum += a[i].w;
}
++sum;
//增加超级节点0,节点0到其余各个节点的边权相同(此题中 边权要大于原图的总边权值)
for( i = m; i < m + n; ++i) {
a[i].u = 0;
a[i].v = i - m + 1;
a[i].w = sum;
}
LL ans = Directed_MST(0, n + 1, m + n);
//n+1为总结点数,m+n为总边数
//ans代表以超级节点0为根的最小树形图的总权值,
//将ans减去sum,如果差值小于sum,说明节点0的出度只有1,说明原图是连通图
//如果差值>=sum,那么说明节点0的出度不止为1,说明原图不是连通图
if(ans == -1 || ans - sum >= sum)
puts("impossible");
else
printf("%lld %d\n",ans - sum, pos - m);
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: