您的位置:首页 > 其它

HDU 2602 Bone Collector 解题报告(dp入门题)

2016-08-04 09:05 549 查看
[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).
 

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

 
[align=left]Sample Output[/align]

14

 
#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
int t,n,v,w[1024],p[1024];
int dp[1024];
scanf("%d",&t);
for(int q=0;q<t;q++){
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&v);
for(int i=0;i<n;i++)scanf("%d",&p[i]);//输入物品价值
for(int i=0;i<n;i++)scanf("%d",&w[i]);//输入物品体积

for(int i=0;i<n;i++){
for(int j=v;j>=w[i];j--){//背包填不满,所以此处为倒序遍历
if(dp[j-w[i]]+p[i]>dp[j]){
dp[j]=dp[j-w[i]]+p[i];
}
}

}
cout<<dp[v]<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU dp