您的位置:首页 > 其它

HDU 1222 Wolf and Rabbit

2016-08-03 20:49 351 查看

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7473    Accepted Submission(s): 3746


[align=left]Problem Description[/align]
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 

[align=left]Input[/align]
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

 

[align=left]Output[/align]
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

 

[align=left]Sample Input[/align]

2
1 2
2 2

 

[align=left]Sample Output[/align]

NO
YES

 
判断是否互质的问题

#include<stdio.h>
int GCD(int x,int y)
{
if(x%y==0)
return y;
else
return (GCD(y,x%y));
}
int main()
{
int m,n;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
if(GCD(m,n)==1)
printf("NO\n");
else
printf("YES\n");
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: