您的位置:首页 > 其它

1110. Complete Binary Tree (25)

2016-08-03 15:39 369 查看
Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and
gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:
YES 8

Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:
NO 1


给出一棵树,判断是否是完全二叉树。用BFS的方法遍历这棵树,计算遍历过的节点数,同时更新遍历的最后一个节点的值,遇到某点为-1时跳出循环。最后如果遍历过的点等于总结点数,说明是完全二叉树,否则不是。

代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;

struct node
{
int val;
int left,right;
node():left(-1),right(-1){}
};

int main()
{
int n;
cin>>n;
vector<node>tree(n);
vector<bool>isroot(n,true);
for(int i=0;i<n;i++)
{
string l,r;
cin>>l>>r;
if(l[0]!='-')
{
int left=atoi(l.c_str());
tree[i].left=left;
isroot[left]=false;
}
if(r[0]!='-')
{
int right=atoi(r.c_str());
tree[i].right=right;
isroot[right]=false;
}
}
int root;
for(int i=0;i<n;i++)
{
if(isroot[i])
{
root=i;
break;
}
}
queue<int>que;
que.push(root);
int count=0,last;
while(!que.empty())
{
int tmp=que.front();
if(tmp==-1)
{
break;
}
last=tmp;
count++;
que.pop();
que.push(tree[tmp].left);
que.push(tree[tmp].right);
}
if(count==n)
{
cout<<"YES "<<last;
}
else
{
cout<<"NO "<<root;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  tree bfs