您的位置:首页 > 其它

POJ 3254 - Corn Fields

2016-08-03 13:45 204 查看
Description

Farmer John has purchased a lush new rectangular pasture composed of M by
N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close
to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input
Line 1: Two space-separated integers: M and
N

Lines 2..M+1: Line i+1 describes row i of the pasture with
N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0

Sample Output
9


这是一道关于放牛的题,题意:给一个NxM的矩形牛要放在肥沃的地方【1表示肥沃,0表示贫瘠】,而且牛与牛之间不能挨着,问所有的情况有哪些,放牛的数量只要大于1就好。
首先用maps存下地图,注意用1存不能放【贫瘠】,0存可以放【肥沃】。
用state存能够放牛的合理情况,即两只牛不相互挨着,还要判断与上一行的牛不能相互挨着。
用ans[i][j]表示在第i行用第j种状态的答案数。
具体提示在代码注释中:
#include <cstdio>
#include <cstring>

const int MOD = 100000000;
int maps[1<<13];
int state[1<<13];
int ans[13][1<<13];//ans[i][j]表示在i行状态为j时放的最多的牛

int main()
{
int m, n;

while (scanf("%d%d", &n, &m) != EOF)
{
memset(ans, 0, sizeof(ans));
memset(maps, 0, sizeof(maps));
memset(state, 0, sizeof(state));
for (int i = 1; i <= n; ++i)
{
for (int j = 1; j <= m; ++j)
{
int num;
scanf("%d", &num);
if (num == 0)///用0存能放牛,1存不能放牛
maps[i] += (1<<(j-1));
}
}
int cur = 0;
for (int i = 0; i < (1<<m); ++i)
{
if (!(i & (i<<1)))///两只牛不相互挨着
state[cur++] = i;
}
for (int i = 0; i < cur; ++i)
{
if (!(maps[1] & state[i]))///合理的情况与地图相符
ans[1][i] = 1;
}

for (int i = 2; i <= n; ++i)
{
for (int j = 0; j < cur; ++j)
{
if (maps[i] & state[j])///第i行与j状态
continue;
for (int k = 0; k < cur; ++k)
{
if (maps[i-1] & state[k])///上一行与k状态
continue;
if (!(state[j] & state[k]))
ans[i][j] += ans[i-1][k];
}
}
}
int ret = 0;
for (int i = 0; i < cur; ++i)
{
ret += ans
[i];
ret %= MOD;
}
printf("%d\n", ret);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM POJ