您的位置:首页 > 其它

POJ 2488 A Knight's Journey

2016-08-03 10:44 591 查看
A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41039 Accepted: 13964
Description


Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany
[Submit]   [Go Back]   [Status]  
[Discuss]


Home Page   

Go
Back  

To top

Source Code
#include <iostream>
using namespace std;
bool vis[100+5][100+5], flag;
int p, q, k;
int next[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};//注意方向数组顺序,优先搜索靠左下的点,以使得字典序较小的先输出
struct node {
int x, y;
}A[3000+5];
bool judge() {
for(int i=1;i<=q;i++)
for(int j=1;j<=p;j++)
if(!vis[i][j]) return 0;
return 1;
}
void dfs(int x, int y, int step) {
A[step].x=x;
A[step].y=y;
if(judge()&&!flag) {
flag=1;
for(int i=1;i<=step;i++) {
char c='A'+A[i].x-1;
cout<<c<<A[i].y;
}
cout<<endl;
return ;
}
for(int i=0;i<8;i++) {
int tx=x+next[i][0], ty=y+next[i][1];
if(tx>=1&&tx<=q&&ty>=1&&ty<=p&&!vis[tx][ty]) {
vis[tx][ty]=1;
dfs(tx,ty,step+1);
vis[tx][ty]=0;
}
}
}
int main()
{
int n;
cin>>n;
for(k=1;k<=n;k++) {
flag=0;
cin>>p>>q;
if(k!=1) cout<<endl;
cout<<"Scenario #"<<k<<":"<<endl;
for(int i=1;i<=q&&!flag;i++)
for(int j=1;j<=p&&!flag;j++) {
vis[i][j]=1;
dfs(i,j,1);
vis[i][j]=0;
}
if(!flag) cout<<"impossible"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: