您的位置:首页 > 其它

poj 3278 Catch That Cow

2016-08-03 10:00 375 查看
Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 75755 Accepted: 23917
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

就是到牛的最短步数(n-1,n+1,n*2)

对于这个题我不想在多说什么,太坑了,我一开始用的模拟队列空间占用太大,,,,(加上我的算法不好)

#include <queue>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

int vis[100005];
struct node
{
int ant;
int t;
};
queue <node> qu;
int n, m;

int Que ()
{
memset(vis, 0, sizeof(vis));

while ( !qu.empty() )
{
qu.pop();
}
node head,tail;

head.ant = 0;
head.t = n;
qu.push(head);

while ( !qu.empty() )
{
head = qu.front();
qu.pop();

if ( (head.t+1 < 100004&&head.t+1 > 0)&& vis[head.t+1] == 0)
{
tail.t = head.t+1;
vis[tail.t] = 1;
tail.ant = head.ant+1;
qu.push(tail);
if ( tail.t == m)
return tail.ant;
}

if ( (head.t-1 < 100004&&head.t-1 > 0)&& vis[head.t-1] == 0)
{
tail.t = head.t-1;
vis[tail.t] = 1;
tail.ant = head.ant+1;
qu.push(tail);
if ( tail.t == m)
return tail.ant;
}

if ( (head.t*2 < 100004&&head.t*2 > 0)&& vis[head.t*2] == 0)
{
tail.t = head.t*2;
vis[tail.t] = 1;
tail.ant = head.ant+1;
qu.push(tail);
if ( tail.t == m)
return tail.ant;
}
}
}

int main()
{
scanf ( "%d %d", &n, &m );

if(n >= m)
{
printf("%d\n",n-m);
}
else
{
printf ( "%d\n", Que());
}

return 0;
}


代码菜鸟,如有错误,请多包涵!!!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: